この記事の所要時間: 135

Apache2.4でこんなエラーが

 AH01630: client denied by server configuration: C:/xampp/phpMyAdmin/

xampp上でphpMyAdminを動かそうとして
イントラネットからやりたかったので
もともとの
httpd-xampp.confで最近localからしかアクセスできなくなっていたphpmyadminを
外部からアクセス出来るように・・・
最後の部分を編集したのでした。

#
# New XAMPP security concept
#
<LocationMatch "^/(?i:(?:xampp|security|licenses|webalizer|server-status|server-info))">
# ↑phpmyadmin削除
    Require local
    ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>

そこと、なぜか上の方にあったディレクティブを変更

    Alias /phpmyadmin "C:/xampp/phpMyAdmin/"
    <Directory "C:/xampp/phpMyAdmin">
        AllowOverride AuthConfig
#        Require all granted
    </Directory>

このRequire all granted をコメントアウトしたのがいけなかった。
ずっと 403エラーの連続・・・・

Require all granted

これで昔の
allow all
と同意・・・らしい。

気をつけよ・・・っと。

この記事が気に入ったら
いいね ! しよう

Twitter で